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Podcast Terms and Definitions 
 

AAC: (Advanced Audio Coding) an audio file that has been compressed (made a 

smaller file size). Often referred to as an MPG-4 AAC file. This is the file format 

used by Apple for Enhanced Podcasting and will have an extension of .m4a. 
 

AIFF: (Audio Interchange File Format) an audio file format, especially used on Mac 

computers. It is not as compressed (small) as AAC files. 
 

Album Art: is usually a jpg image that is added to the podcast and displays when the 

podcast is played in iTunes. For podcasts that are not enhanced, this is the only visual 

image displayed. 
 

Audio: voice/sound/music that is recorded with microphones and played back through 

speakers. Digital Audio is audio that is represented as numeric values the computer 

can understand. 
 

Background Music: music recorded along with the podcast to play in the background. 

Ducking will force the music to reduce volume whenever a person begins speaking. 

Loops in GarageBand make excellent background music. 
 

Broadcast: to transmit audio or video signals, usually for a radio or television show. 

Also used as a noun to describe a radio or television show. 
 

Buttons: term for bumper music used by noncommercial radio stations.  
 

Bumper Music: very short (3-5 seconds) bits of music played as transitions between 

segments or parts of a podcast. In commercial radio broadcasts, bumpers were often 

used as transitions into advertisements. Bumpers are also known as Buttons or 

Sweepers. 
 

Chapter Artwork: similar to album art, chapter artwork marks the chapters of an 

enhanced podcast and will appear in iTunes as different segments or chapters of the 

podcast are played.  
 

Chapters: enhanced podcasts allow the creation of chapters to mark breaks in the 

podcast topic. Chapter markers can be inserted to indicate where the content of the 

podcast changes. Along with chapter markers, you can also insert chapter titles and 

chapter artwork. 
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Ducking: will reduce the volume of background music or sound effects so voices can 

be better heard. This feature is available in GarageBand 3. 
 

Enhanced Podcast: a podcast that contains chapters, URL’s or other content beyond 

that of a standard MP3 podcast. Enhanced podcasts are AAC (m4a) files. 
 

Foley: sound effects added to podcasts. Named after Jack Foley who became famous 

for creating sound effects for movies. 
 

Host: the main or regular commentator/speaker on the podcast. 
 

iTunes: an aggregator or “podcatcher” that can retrieve and play podcasts. 
 

Jingles: in GarageBand 3, jingles are complete background music sound tracks, usually 

available in 3 different lengths. 
 

Loops: a collection of professionally recorded music clips included in GarageBand. 
 

MP3: (MPEG-1 Audio Layer 3) is a type of audio file that has been compressed. 

Podcasts that are not enhanced are often MP3 files. 
 

Podcast: a name coined in 2004 that combines iPod and broadcast. A podcast is a 

broadcast of MP3 or AAC files transmitted over the Internet. Podcasts are 

syndicated, which means listeners can subscribe to the podcast and receive future 

episodes through automatic download into iTunes or another “podcatcher.” 
 

Sound Effects: GarageBand 3 contains a variety of sounds that can be included in 

podcasts such as a cow moo or a traffic helicopter. 
 

Stingers: in GarageBand 3, stingers are short sound clips used for emphasis. 
 

Sweepers: short (3-5 seconds) bits of music played as transitions between segments 

or parts of a podcast. Sweepers are similar to bumpers or buttons. 
 

Teaser: a ‘sound bite’ used by the podcast host at the beginning of the podcast to 

generate interest in the topic of the podcast or in segments yet to be heard. 
 

Walla: name for crowd sound effects. 
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Westside Community Schools  

District Guidelines for Podcasting 
 

 
Do not podcast confidential material about students, staff or the district. 

 

Consider privacy issues. Identify each person in your podcast at the beginning of the 

podcast and never record/broadcast someone without their permission and 

understanding. 

 

Be aware of your tone of voice. Pay attention to not only what you say, but also how 

you say it. Your tone of voice can change the meaning of the words you say. 

 

Follow the podcast quality guidelines to create the highest quality podcast possible 

based on the resources you have. Listen to other podcasts to improve yours. 

 

Review your content to keep it of the highest quality as well. Remember that you are 

representing the students/staff/school/district to the public in your podcast. 

 

 If you are invited to participate in a non-Westside podcast, treat that opportunity in 

the same manner as any interview request from a reporter. Contact Peggy Rupprecht, 

Director of Communications, prior to the podcast. 

 

Before you podcast, consider if podcasting is the best method to disseminate the 

content to your audience. 

 

Remember that the MP3 or AAC files of your podcast can be saved and distributed. 

They have the potential to last a long time. Don’t podcast something that may come 

back to haunt you or embarrass your students/staff/school. 
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Podcasting can provide opportunities for students to engage in learning that meets 

standards in all curriculum areas. The following is a partial list of Program Outcomes 

and Indicators for individual content areas for Westside Community Schools. 

Podcasting is not limited to these areas, they are merely a place to start. 

 

English 

• Speaks effectively for a variety of purposes and audiences. 

• Writes clearly and correctly for a variety of purposes and audiences. 

 

Math  

• Uses mathematical processes. 

o Communicates effectively using the language of mathematics. 

 

Science 

• Communicates results and conclusions of an investigation. 

o Provides oral or written explanation of the investigation that justifies 

the results to others. 

 

Social Studies and History 

• Communicates findings related to one or more hypotheses. 

 

Art  

• Interpret and critique artwork. 

o Communicate personal ideas, attitudes, and feelings through visual art 

forms. 

 

Business  

• Applies effective communication and human relations skills in business and 

social settings. 

o Uses appropriate written communications. 

o Communicates orally in an effective manner. 

 

 

 

How Does Podcasting  

Fit in My Curricular Area? 
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Foreign Language  

• Communicates effectively in the target language. 

o Speaks clearly and communicates ideas. 

o Writes to convey information and ideas. 

 

Health & Physical Education 

• Practices and advocates health enhancing behaviors.  

• Comprehends concepts related to health promotion and disease prevention. 

 

Music 

• Assesses personal performance and the performance of others using the 

vocabulary of the discipline. 

o Listens discriminately. 

• Experiences and gains an appreciation for music of various cultures and 

historical periods. 

o Identifies and/or performs examples of music from various historical 

periods and cultures. 
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Student Rules and Responsibilities 
 

 
 

 

1. No confidential information should be included in your Podcast.   

Last names, phone numbers, addresses, birthdates, or social  

security numbers should not be given in a Podcast. 

 

2. Do not talk about other people without their permission. 

 

3. Treat everyone with respect. 

 

4. All information and language in your Podcast must be school appropriate. 

 

5. Never overtly or covertly attack or disrespect someone in your Podcast. 

 

6. Podcast must be content driven. (It should be directly related to the 

topics and information being discussed in class.) 

 

7. You will be accountable for the information that you produce and publish. 

 

8. Make sure your Podcast information is factual. 

 

9. Have fun and spend your time working on task. 

 

10.  List all sources and follow copyright laws. 

 

 

I have read and understand the “Student Rules and Responsibility” and 

agree to abide by them.  

________________________________ 

 Student Signature 
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Ideas for Podcasting 
 

A podcast’s content can be anything conveyed by an audio or video file. Instructors 

can easily create a podcast of daily assignments and lectures from class, and publish 

it for all of their students. Students can likewise create and publish content and 

deliver it to their teachers or to other students. 

 

 

A recorded lecture     Test reviews 

A foreign language lesson    Play by play of an event in history  

A demonstration of biology principles  Readings of poetry 

Book review      Novel reviews 

Radio show      Weather reports 

Exercise workouts     Healthy nutrition guides 

Mythology      Learning Spanish 

Talk show host     Humor of the day 

Science Fridays     Manners 

Bullying      Friendships 

Class plays      Clubs and organization 

Announcements     Field trips (zoo, Omaha World Herald) 

Our class story     Teacher news 

Current events     Question of the day 

Absent student (send them to the podcast for lectures!) 

 

How do children benefit from making a podcast? 

 
• It gives them a potential audience of thousands for their work. 

• It's great for developing literacy skills (writing scripts, setting up interviews 

etc), allows children to develop and practice their speaking and listening skills, 

and they also learn some amazing ICT skills. 

• Podcasts can be interactive, and the audience can be invited to send their 

comments, giving valuable feedback to the children about their work. 

• I've found that making a podcast is also great for developing teamwork skills. 

The children always work together really well, as they're always keen to make a 

great show. 
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Recording Tips 

 
Smile when recording 

 

Talk as if you are talking to a friend 

 

Don’t take yourself too seriously 

 

Be organized don’t ramble 

 

Prepare, practice and practice more 

 

Record in short segments 

 

Avoid background noise 

 

Avoid dropping off volume at the end of words 

 

Avoid “popping” in the microphone 

 

Don’t eat the microphone 

 

Avoid talking too fast 

 

Breathe and cough away from the microphone 

 

Annunciate 

 

Use light background music 
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Recording a Podcast 

using GarageBand 2 and iTunes 
 

1. GarageBand is a processor/memory intensive application. Close all other 

applications before using GarageBand. 

2. Open GarageBand and on the welcome screen click Create New Song. If 

GarageBand automatically opens a previous project, click the red close button 

and wait a moment for the opening screen to appear or go to File>New. 

 

 
 

3. A New Project box will appear. Type a name for your podcast episode in the 

Save As box, choose (and remember) a location to save it to in the Where drop 

down. Leave the other settings (Time, Tempo, etc.) at their defaults. Click the 

Create button. 

 

 
 

4. In the GarageBand window that appears, there will be a Grand Piano track. You 

may delete it by going to Track>Delete Track in the menu bar. You may also click 

on the red close button of the miniature piano that is on your screen. 

 

5. Next, add a new track by going to Track>New Track in the menu bar. From the 

options select Real Instrument vocals and No Effects. Click on the Create 

button. 
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6. In the menu bar under GarageBand go to Preferences>Audio/MIDI and select 

Built-in Audio for both the Audio Output and Audio Input if you are going to use 

the built-in microphone in your laptop. 

 

 
 

If you are using an external microphone, you will need to go into the System 

Preferences of your laptop (Apple>System Preferences) and click on the Sound icon 

under Hardware. A Sound screen will appear. Click on the Input button. Select the 

device you want to use. The screen shot on the next page shows that the USB 

microphone AK5370 has been selected. Speak into the microphone and test the sound 

levels. Adjust the volume if you are not seeing the ovals in the Input Level “march” 

about halfway across the display. 

 

Feel free to experiment 

with other Vocals options 

such as Helium Breath. 
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7. You are now ready to do a test recording. In GarageBand click the Record 

button to begin, and speak clearly into the microphone. Click the Stop button to 

stop recording. Click the Rewind button or Z to go back to the beginning. Click 

Start/Stop or the Spacebar to listen to your recording. 

 

 
 

 It is a good idea to test the sound levels here also. If your sound levels are too loud 

or “hot” you will see orange and/or red indicators. Stay in the “green” to avoid 

distortions. 

 

 

 

 
 

You can also change to Mono if your microphone is not recording in stereo (only one 

green sound level appears to work). Go to Track info and select one of the Mono 

channels. The screen shot on the next page show this. 

 

Green Orange and Red 
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8. Once you are satisfied with the sound you may begin recording your podcast. To 

add additional sounds, (such as background music or ‘sweepers’ between sections 

of your podcast) add new tracks and drag GarageBand loops or other sound 

effects in place. When you are happy with your recording go to File>Save. 

 

9. Export to iTunes: On the menu bar go to File>Export to iTunes. GarageBand will 

create a “mixdown” of your podcast and put it in the iTunes Library as an AIFF 

file. You will need to convert this AIFF file into an AAC file. 

 

 
 

10. Adding artwork: Once your podcast is in iTunes you can highlight it and click on 

the Album Artwork square in the lower left corner of the iTunes screen. You 

may drag an image into this space if you wish. This image could be your school 

logo or a design you create:  image, text or both (see picture on next page). 

Consider an image that will immediately identify your podcast.  You will probably 

use it for every podcast. 

 

Be aware of copyright restrictions. Do not use clip art that does not specifically 

grant you Internet usage rights. You may create your own album art in Word or 

AppleWorks Painting. Keep size to 300x300 pixels and save as .jpg or .png file. 

 

Select Mono if you are only 

seeing green bars on one sound 

input line when you speak into 

your microphone. 
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11. After adding album art, you are ready to convert your podcast to an AAC file. 

You will need to change the large AIFF file into a smaller AAC file for 

Podcasting. To do this, on the iTunes menu bar go to iTunes>Preferences and 

click on Advanced. In the Advanced screen click on Importing and under Import 

Using select AAC Encoder. Under Setting select Spoken Podcast. 

 

 
 

12. Now that your settings are in place, select the podcast in your iTunes Library 

then in the menu bar go to Advanced>Convert Selection to AAC. iTunes will 

convert your podcast to an AAC file and add it to your iTunes Library. You will 

see two apparently identical podcasts. One is an AIFF file and one is an AAC. 

Use File> Get Info to find the AAC file. You can now drag the AAC file out of 

your iTunes library and on to your desktop. 

 

13.  After dragging the AAC file on to your desktop it will have an m4a extension. 

Your podcast is now ready for posting on your building’s podcast server. Contact 

your building’s Podcast Team. The Podcast Team will post your podcast file. 
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Recording a Podcast 

 using GarageBand 3 (Regular or Enhanced) 
 

 

1. GarageBand is a processor/memory intensive application. Close all other 

applications before using GarageBand. 

 

2. Open GarageBand and click New Podcast Episode button. If GarageBand 

automatically opens a previous project, click the red close button to display the 

opening screen where the New Podcast Button is visible or go to File > New> New 

Podcast Episode. 

 

   
 

3. Type a name for your podcast episode and select a location (and remember that 

location!) to save the podcast file. Click the Create button.  

4. In the GarageBand window that appears, you will see a Podcast Track, two vocal 

tracks, a Jingles track, and a Radio Sounds track. Before you begin recording, 

you will need to set some preferences. 

 

             
 

 

 

These are the default tracks that 

GarageBand 3 will create for you.  

You may decide not to use some of 

them, or to create new tracks. 
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5. In the menu bar under GarageBand go to Preferences in the drop down menu.  

a. Select Advanced and set the Maximum Number of Tracks to 8 for both 

Real Instrument Tracks and Software Instrument Tracks. Set Voices per 

Instrument to 10 sampled, 5 other. 

b. Select Export and under Audio Podcast Settings select Spoken Podcast 

for smaller files or Musical Podcast if you plan to incorporate several 

loops such as jingles or sound effects. The Publish Podcast box should 

also be checked to keep artwork at 300x300 for best display purposes. 

c. Select Audio/MIDI and select “Built-in Audio” for both the Audio Output 

and Audio Input if you are going to use the built-in microphone in your 

laptop.  

 

 
 

6. If you are using an external microphone, you will need to go into the System  

Preferences of your laptop (Apple>System Preferences) and click on the Sound  

icon under Hardware. A Sound screen will appear. Select the device you want  

to use. Test the input levels and adjust the volume if you are not seeing the  

ovals in the Input Level march about halfway across the display. 
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7. You may either select one of the vocal tracks (male/female) to record yourself  

speaking, or add a new basic track by going to Track>New Basic Track in the  

menu bar. You can also go to Track>New Track, Select Real Instrument, and  

click on Create. 

 

         
 

This will also give you a Basic Track with No Effects. However, you will be able to see 

additional choices in the Track Info box in the lower right hand side. Scroll down and 

click on Vocals. In the left hand column click on Epic Diva, for instance. You will see 

the No Effects track change to Epic Diva. 

 

          
 

8. You are now ready to do a test recording. Select a track (either the female or 

male voice default track or a track you have added) and click the Record button. 

Speak clearly into the microphone. Click the record button again to stop 

recording. Click the Rewind button or Z to go back to the beginning of  

the recording. Click the Start/Stop button or the spacebar to listen to your  

recording. 
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It is a good idea to test the sound levels here also. If your sound levels are too loud 

or “hot” you will see orange and/or red indicators. Stay in the “green” to avoid 

distortions. 

 

 

 
 

You can also change to Mono if your microphone is not recording in stereo (only one 

green sound level appears to work). Go to Track info and select one of the Mono 

channels. 

 

 
 

9. Once you are satisfied with the sound you may begin recording your podcast. If 

you do not plan to use one of the default tracks, such as the Male Voice, you may 

delete it by going to Track>Delete Track.  

 

10. To add additional sounds (background music, sweepers, sound effects), you can  

        click on the loop browser to include regular GarageBand loops or select  

     something from the Podcast Sounds portion of the loops browser. You may drag    

     these to the Jingles track or add new tracks. You may also use the Radio  

     Sounds track with the musical typing keyboard (in the menu bar go to  

     Window>Musical Typing). 

                                                    

Green Orange and Red 

Select Mono if you are only 

seeing green bars on one sound 

input line when you speak into 

your microphone. 
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11. If you are using the additional tracks for jingles, sound effects, etc, you will  

need to enable “Ducking” so these additional sounds don’t drown out your spoken  

words. In the menu bar go to Controls>Ducking and make sure there is a check  

mark in front of the word Ducking. This will allow you to designate primary and  

secondary tracks by clicking on the up or down arrow. You may also adjust track  

volume controls or make changes in the Ducking Amount in the Master Track  

(Track> Show Master Track) if you are not satisfied with the way your podcast  

sounds. 

 

 
 

Master Track info. 

 
 

Enhanced Podcast:  

You will use the Podcast track, Podcast Track Editor, and the Media Browser  

(Control > Show Media Browser) to create an enhanced podcast. 

 
 

Episode Artwork or Album art:  

This could be your school logo or a design you create: image, text or both. Consider an 

image that will immediately identify your podcast. You will probably use it for every 

podcast 

1. Be aware of copyright restrictions - don’t use clip art that does not 

specifically grant you Internet usage rights. 

2. You may create your own album art in Word or AppleWorks Painting. 

3. Keep size to 300x300 pixels and save as jpg or png file. 

4. Although you can add album art without the use of the Podcast track, if you 

are creating an enhanced podcast, you might as well use the Podcast track 

for album artwork also. Click on the Podcast track. Drag an image from the 

Media Browser into the Episode Artwork space in GarageBand. (It will 

automatically appear in iTunes when you are finished).  

 

Click upper 

arrow for 

primary track 

and lower arrow 

for secondary 

tracks 
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Adding Chapters:  

You can add chapter markers that will help your listeners skip to specific sections of 

your podcast. Move the playhead to the point in the podcast where you want to add a 

chapter marker. Click on the Add Marker button. 

 

 

 
 

 
 

 

 

 

Chapter Artwork:  

You can also drag images from the Media Browser onto the Artwork column. You will 

see the images appear in the Podcast track above. 

 

Chapter Titles, URL Titles, and URL’s:  

You can also give each chapter a title, and add relevant URL’s (and URL titles). Just 

click in the appropriate column and type in your information. Any URLs you include will 

appear as clickable links on the podcast artwork. You must use the entire URL 

address (i.e.: include the http:// portion). 

 

Episode Info:  

This is also accessible by clicking on the Podcast track. Go to Track>Show Track Info 

or click on the “i” symbol. You will be able to set a Title, Artist, Parental Advisory 

Playhead 

Click to add chapter markers 
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(Clean, of course) and a Description. This is important information that you should 

always provide to your listeners. 

 

  
 

Exporting your podcast: 

Go to File>Save when you are finished with your podcast then go to Share>Export 

Podcast to Disk. GarageBand will put it on your desktop (or whatever location you 

select) as an .m4a file. 

 

 
 

It may take several seconds for GarageBand to create the “mix down” of your 

podcast. 

 

 
 

If you want to test your podcast, click on the m4a file and iTunes will open and play it 

for you. 

 

Your podcast is now ready for posting on your building’s podcast server. Contact your 

building’s Podcast Team. The Podcast Team will post your podcast file. 
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6 Traits Writing and Podcasting 101 
 
What are the 6 traits of writing? A metaphor 

• Ideas and Content – if you think of writing as a closet full of clothes the 

ideas and content are your outfits – what goes into your writing, what the 

writing is all about! Ideas must be presented clearly and developed fully. 

• Organization – how your closet is arranged – some of you have shirts on one 

side, pants on the other, or maybe you organize by color – but usually there is 

some sort of organizational pattern – just like your writing. There should be a 

logical flow to the writing – chronologically or an intro with main points and 

conclusion. 

• Voice – those t-shirts that you have with attitude – you know the ones that say 

“Princess”, “Drama Queen”, “Stud” – you get my drift – the more personality 

you show and put into your writing the more interesting it will be! The voice in a 

paper makes it uniquely yours – a paper doesn’t need to sound robotic or 

monotonous – add your own flair! 

• Sentence Fluency – in your closet sometimes you have short shorts, long 

Bermuda shorts, capris, and jeans – you have different lengths of pants and so 

should your sentences! Mix in some long compound sentences with short choppy 

sentences, always read your paper out loud so you can hear what it sounds like! 

• Word Choice – that fabulous pair of shoes that goes with that outfit – they 

add just that little extra touch – word choice needs to be descriptive and your 

words need to show what is going on not tell what is going on! If the dog didn’t 

just run towards the girl – tell us what it really did – the dog sprinted towards 

the little girl with a pink and green dress – show don’t tell! 

• Conventions – boxers or briefs – the undergarments that keep everything in 

place but don’t show! You need correct spelling, usage and grammar within your 

writing – without good conventions the reader will have a hard time with your 

paper! 

 

 

Why should we focus on the 6-traits in any podcast that we create? If writing is a 

building NCA goal then we all need a basic framework to follow! Not sure how to 

assess 6-trait writing – visit www.nde.state.ne.us/stars/writing/scoringguide8.pdf. 
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Sample Rubric for Evaluating Podcasts 
 

This rubric should only be used for the final podcast project.  Use the 6-Traits 

rubric for evaluating the script. 
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Teacher Guide For Class Podcast 
 

Basic Outline for Class Podcast: 

1. Intro Song (max 15 seconds) 

2. Welcome from Hosts 

a. Use student first names only. 

b. Have students describe what will be discussed in this episode. 

3. Transition Music (max 5 seconds) 

4. Segment 1 

5. Transition Music (max 5 seconds) 

6. Segment 2 

7. Transition Music (max 5 seconds) 

Additional Segments follow similar pattern as above. 

8. Closing Comments 

9. Ending Music (max 15 seconds) 

 

Keys to success: 

• Have students brainstorm for their show before they begin writing: 

o Have students identify Audience for the podshow.  

o Make sure the show is relevant to class curriculum and matches an 

essential learning or indicator. 

o Have fun and be creative. 

• Have students write their script first. 

• Have students practice…practice…practice before recording their 

segment. 

• Have students work on any music and sound effects, after recording of 

segments are completed. 

• Use only copyright free music. Garageband has lots of great loops and 

sounds to use. For some of your students, have them use these sites to 

find additional copyright free music. 

 

Segment Ideas: 

   

 
 

• Holiday Spotlight 

• Website Spotlight 

• Riddle 

• Jokes 

• Late Night Monologue 

• Word of the Day 

• What’s Happening in Class 

• Did you know? 
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Class Podcast Template 
Intro: 

Intro song (max 15 seconds): _____________________________ 

(Use copyright free material; pre-recorded loops from GarageBand or sounds 

from teacher-approved web sites.) 
 

Welcome from hosts: 

 Reminder:  

• Use only first names (no last names). 

• Introduce show and give brief summary of what will be discussed in 

show. 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 
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Transition Music (max 5 seconds): ______________________________________ 

(Use copyright free material or pre-recorded loops from GarageBand.) 
 

Segment 1: 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

 

Transition Music (max 5 seconds): ______________________________________ 

(Use copyright free material or pre-recorded loops from GarageBand.) 
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Segment 2: 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

 

Transition Music (max 5 seconds): ______________________________________ 

(Use copyright free material or pre-recorded loops from GarageBand.) 
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Segment ____: 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

 
Transition Music (max 5 seconds): ______________________________________ 

(Use copyright free material or pre-recorded loops from GarageBand.) 
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Closing Comments: 
______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

______________________________________________________________ 

 

Ending Music (max 15 seconds): ________________________________________ 

(Use copyright free material or pre-recorded loops from GarageBand.) 
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Teacher Guide For Individual Student Podcasting 
 

1. Use the script on the following pages for individual student podcasting 

projects. 

2. Have students identify the topic of their project and the required information. 

3. Have students write their script on the left hand side of the page and list any 

special sound effects they wish to include in their final project. 

 

Keys to success: 

• Have students brainstorm for their show before they begin writing: 

o Have students identify an audience for the podcast.  

o Make sure the podcast is relevant to class curriculum and matches an 

essential learning or indicator. 

o Have fun and be creative. 

• Have students write their script first. 

• Have students practice…practice…practice before recording their segment. 

• Have students work on any music and sound effects, after recording of the 

script is completed. 

• Use only copyright free music. GarageBand has lots of great loops and sounds 

to use. 
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Individual Student Podcast Script  
 

Topic: _____________________ 

 

Required Content/Information Needed for Project: 

 

 

 

 

 

 

 

Intro Music (15 seconds max): _______________________________________ 

 

(Use copyright free material: pre-recorded loops from GarageBand or sounds 

from teacher-approved web sites.  Remember it is important to pick the right 

type of music to set the proper “mood” for your show.)  
 

Your Script: 

(Write your script that you will read when you record your voice.  In the right column 

include any sound effects you wish to include in your final show.) 

 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

Sound Effects 

1. 

2. 

3. 

4. 

 

5. 

6. 

7. 

8. 
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_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

_____________________________________________ 

Sound Effects 

 

Closing Music (15 seconds max): ______________________________________ 
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How to Storyboard Your Podcast 
Storyboarding allows you and your students to plan the entire podcast before 

recording ever begins. It is also much easier to make changes on paper than to 

edit the recording. The following storyboard example and blank storyboard 

template can help your students plan their Podcast. 

 

Voice Over – Students write their content here. This content can be taken from 

their previously written rough draft. When students edit and rewrite content they 

improve both the quality of the content and their writing skills. They also become 

more familiar with the content prior to recording the podcast. 

 

Transitions – These are the areas where voice, sound effects and music interact.  

Your students should experiment with a variety of transitions to determine which, 

if any, will work best for their podcast. 

 

Effects – Sound effects are the bells and whistles that make a podcast unique and 

fun. Students might add anything from crickets chirping to dogs barking. 

 

Music – This is where your student’s personalities will shine through. Let them 

experiment with GarageBand loops – but be aware of copyright issues. 

 

Storyboard Example 

Voice Over – “Hi and welcome to podcasting 101!  I am your host for today.” 

Transitions – Fade music into vocal 

Effects – Hands clapping 

Music – Original song from GarageBand 

 

 

 

 

 

 

Intro music  

 

Transition -  fade to 

voice over 

 

 

Voice Over  

 

“Hi and welcome to 

podcasting 101! I am your 

host for today.” 

 

Effect  
Hands clapping 

Transition  

 

Fade clapping out to 
music 
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Storyboard Template 
Voice Over: 

Transitions: 

Effects: 

Music: 
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Digital Storytelling 101 

 
Want a great way for students to tell a story from a new perspective? Then digital 

storytelling is the way to go. Let your students loose with a camera or two and they 

will find new and exciting ways to present a narrative. 

 

1. Find a story to tell. Let students find an important story based on curriculum 

content. Encourage students to write from a unique perspective. For example: a 

Plains Buffalo could tell a unique story about Plains Indians; the character of 

Gabriel from The Giver would offer a very unique perspective on life; a triangle 

could tell the story of how Pascal came to discover what is now named for him. 

The more unique the perspective the more fun students will have! Always 

remember to follow the 6 traits of writing when students are preparing the 

text of their stories! 

2. Once students have a good story to tell, they need to storyboard their ideas 

for still photos or video shots. Have students use the storyboard from their 

podcast to create the sequence of their camera shots.  

3. When students have a story and storyboard prepared, they are ready to take a 

camera out into the world! Remind them about good photography/video skills 

such as focus, use of zoom, avoiding background clutter and using good lighting. 

4. Video shots require more patience than still photos. Remind students to use a 

tripod if possible since any hand movement during filming will be noticed in the 

final product. If they are going to record dialog during the shot they need 

silence around them, and must either speak up or use a microphone to be heard! 

5. After filming is complete, let students loose in iMovie. They should use their 

storyboards to edit the movie as they include transitions, music, and voice-

overs. Remind them that some of the most powerful moments in movies come 

from the music used in the background! 

6. Finally, once they have the final product hold a class showing. Let students 

explain why they chose certain camera angles, still photos, or why the music 

helped to create the mood. Most importantly, allow them to explain why this 

story meant so much to them – you will be surprised at how much they have 

learned about their content! 

 

For a very detailed website dedicated to digital storytelling please visit this link: 

http://www.storycenter.org/memvoice/pages/cookbook.html. 
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Making a Podcast Drama 
 

Directions: Use this template to help you and your group to create your podcast 

drama. 

 

Pre-Production 
 

Topic:_________________ 

 

Required content / information that needs to be included in your project: 

 

 

 

 

 

 

 

 

 

Brainstorm: 

Brainstorm ideas for your stories below or on a separate sheet of paper. 

 

Story Genres to choose from: 

Circle the story genre your group is using for this project. 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

• Kinship Stores 

(Friends/Family) 

• Myths, Legends, Tales 

(past, present, future) 

• Informational Stories 

• Persuasive Stories 

• Science Fiction 

• Other 

__________________ 

• Memorial Story  

• Personal Story 

• Adventure Story 

• Accomplishment Story 

• Personal Story 

• Recovery, Love, 

Discovery, Personal 

Quest 

1. 

2. 

3. 

4. 

5. 

6. 

7. 

8. 
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Problem: 
Identify the problem or problems that your character or characters must overcome: 

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________ 

 

Pitch: 
Write a 3 to 5 sentence “blurb” of your story to tell another student group or 

teacher to “sell” your story idea. 

______________________________________________________

______________________________________________________

______________________________________________________

______________________________________________________ 

Preparing your story: 
Story Flow: 

Most stories follow a similar “outline.” Using this framework and your work above, it is 

now time to storyboard your story. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Adventure Begins (Your character(s) begin their journey). 

2. Conflict (Your character(s) run into some type of problem they cannot solve). 

3. Resolution (Your character(s) from their experience solve their problem). 

4. Adventure Ends -Lesson Learned (Your character(s) learn an important lesson). 
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Create your storyboard using the Storyboard Handout. 

Write your script. 

Practice, practice, practice before recording your script. 

 

Production: 
• Record your script.  

 

Post-Production: 
• After you have recorded your script, add special effects sounds, and music to 

your drama. 

Storyboard: 

1.  In each square illustrate what you want to do. Label each square as: Beginning, ,  

Problem (tension), Solution (resolution), transformation, and End (Closure  

learning). 
2. Think about any special effects (sounds) and music you would want to include in  

this project. Remember, the music and sounds should help add to the mood and  

feel of the story. 

a. An example is using scary music for a scary point in the story. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. 2. 3. 

4. 5. 
 

6. 
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7. 
 

8. 
 

9. 
 

10. 
 

11. 
 

12. 
 

13. 
 

14. 
 

15. 
 

16. 
 

17. 
 

18. 
 


